Performance Degradation

Incident Report for RebelMouse

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 13:13 EST

Monitoring

We've experienced a short period of increased error rate. Our team is investigating the issue.
Posted Feb 04, 2026 - 12:39 EST
This incident affected: Full Platform.