Editorial Tools Issues
Incident Report for RebelMouse
Postmortem

Summary:

Today, our MongoDB cluster experienced an overload incident, resulting in system instability. We took immediate action to resolve the issue, and after a thorough investigation, we identified the root cause of the problem. It was discovered that the issue stemmed from a bug in the routing configuration feature. This bug caused an abnormal number of requests to the database, leading to its overload.

Incident Resolution:

We've acted swiftly to address the issue. Our team successfully deployed a fix, and as a result, system load returned to normal levels.

Preventive Measures:

Our QA team has been promptly informed of the incident, and they are now tasked with creating comprehensive tests to cover this scenario. This proactive approach will help us prevent similar incidents from occurring in the future.

Posted Oct 11, 2023 - 10:57 EDT

Resolved
This incident has been resolved.
Posted Oct 11, 2023 - 07:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2023 - 07:07 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 11, 2023 - 06:45 EDT
Investigating
Editors may currently experience unavailability of publishing tools. Our team is already working on the recovery.
Posted Oct 11, 2023 - 06:44 EDT
This incident affected: Logged In Users.