Godaddy DNS Resolution Degraded

Incident Report for RebelMouse

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 17:45 EST

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2025 - 17:13 EST

Monitoring

We are aware of an ongoing issue affecting GoDaddy's DNS services. If your domain uses GoDaddy for DNS management, you may experience intermittent connectivity or resolution failures.

This issue is on GoDaddy's end and their team is working on a resolution. We are actively monitoring the situation.

Impact: Sites using GoDaddy DNS may be temporarily unreachable or experience slow loading times.

Action required: No action needed from your side at this time. If you're unsure whether you use GoDaddy DNS, please reach out and we can confirm.

We'll update this status once GoDaddy reports the issue resolved.

https://status.godaddy.com/
Posted Dec 12, 2025 - 17:08 EST
This incident affected: Third-party.