External Scripts Loading Issue

Incident Report for RebelMouse

Postmortem

Chronology of the incident (UTC)

  • Mar 11, 2025 8:32 AM - RebelMouse deployed an update to improve the performance and resource utilization.
  • Mar 11, 2025 2:33 PM - RebelMouse support team received the report about the Chartbeat script not loading.
  • Mar 11, 2025 2:43 PM - RebelMouse tech team started to investigate the issue.
  • Mar 11, 2025 3:01 PM - The root cause was identified, and appropriate measures were taken to restore functionality.
  • Mar 11, 2025 3:01 PM - The incident was resolved.
  • Mar 11, 2025 3:07 PM - The clients were informed about the incident resolution.

The impact of the incident

During the incident Comscore and Chartbeat scripts were not loaded as expected.

The root cause

The incident was caused by a recent update aimed at improving performance and resource utilization. As part of this update, the node handlers were refactored to explicitly define the data they require and how they use it for rendering content. However, this refactoring inadvertently altered the way external scripts, including those for Chartbeat and Comscore, were initialized or executed. As a result, these scripts stopped functioning as expected, leading to data collection issues.

Actions taken

  • The update was rolled back and returned to the development team for further investigation.
  • The QA team is developing new test cases to prevent similar issues in future deployments.
Posted Mar 12, 2025 - 15:16 EDT

Resolved

We are currently investigating this issue.
Posted Mar 11, 2025 - 10:33 EDT